Jak zaktualizować Joomla 1.7 do 2.5?

Aktualizacja Joomla do wersji 2.5.0Niedawno pojawiło się najnowsze wydanie Joomla 2.5.0 dla którego przewidziany jest długomiesięczny okres wsparcia - minimum 18 miesięcy.

Aktualizacja z wersji 1.7 do 2.5.0 nie powinna sprawiać problemów dla większości administratorów. Poniżej przedstawiam krok po kroku jak przeprowadzić aktualizację Joomla! z wersji 1.7.3 do 2.5.0.

Krok 1

Zaloguj się do zaplecza swojego serwisu, następnie w menu Rozszerzenia kliknij pozycję Instalacje. W oknie Instalacje: Instalator kliknij zakładkę Aktualizacje.


Aktualizacja Joomla! do wersji 2.5.0 - Okno Instalacje: Instalator

Krok 2

Kliknij przycisk Oczyść pamięć podręczną, a następnie przycisk Znajdź aktualizację

Aktualizacja Joomla! do wersji 2.5.0 - Okno Instalacje: Aktualizacja

Krok 3

Zaznacz najnowszą aktualizację a następnie kliknij przycisk Aktualizuj


Aktualizacja Joomla! do wersji 2.5.0

Jeżeli wszystko przebiegło jak należy, to zobaczysz ekran informujący o sukcesie zakończonej aktualizacji.

Aktualizacja Joomla do wersji 2.5.0 - podsumowanie aktualizacji

Zauważysz zapewne, że pojawiła się nowa zakładka o dziwnej nazwie COM_INSTALLER_SUBMENU_DATABASE. Nazwa ta wyświetlana jest dlatego, że nie masz jeszcze zainstalowanego pakietu języka polskiego dla wersji 2.5.0.

Krok 4

Pobierz pakiet języka polskiego dla Joomla! 2.5.0 (Kompletny pakiet języka polskiego do Joomla! 2.5.0) zapisując plik archiwum w dowolnej lokalizacji na Twoim dysku.

Krok 5

Kliknij w oknie Instalacje: Instalator zakładkę Instalator.

Instalacja pakietu języka polskiego dla Joomla! 2.5.0

Kliknij przycisk Przeglądaj, wybierz zapisany plik z pakietem języka polskiego (pl-PL_joomla_lang_full_2.5.zip.zip), następnie w okienku Wysyłanie pliku kliknij przycisk Otwórz.

Instalacja pakietu języka polskiego dla Joomla 2.5.0 - Okno Wysyłanie pliku 

W polu tekstowym Plik pakietu powinien pojawić się wpis z dokładną ścieżką dostępu i nazwą pliku z pakietem języka polskiego dla Joomla 2.5.0. Teraz kliknij przycisk Wczytaj plik i zainstaluj.

Instalacja pakietu języka polskiego dla Joomla! 2.5.0 

Po chwili zobaczysz informację o pomyślnym zainstalowaniu pakietu języka polskiego. Zauważ, że nastąpiła zmiana nazwy zakładki ;-)

Podsumowanie instalacji pakietu języka polskiego dla Joomla! 2.5.0

 

Krok 6

Pobierz pakiet języka polskiego dla edytora TinyMCE (Pakiet języka polskiego dla edytora TinyMCE) zapisując plik archiwum w dowolnej lokalizacji na Twoim dysku.

Krok 7

Kliknij w oknie Instalacje: Instalator przycisk Przeglądaj, wybierz zapisany plik z pakietem języka polskiego dla edytora tekstu TinyMCE (tinymce_lang_pack_pl_3.4.7_j2.5.zip), następnie w okienku Wysyłanie pliku kliknij przycisk Otwórz.

Instalacja pakietu języka polskiego dla edytora tekstu TinyMCE - Okno Wysyłanie pliku 

W polu tekstowym Plik pakietu powinien pojawić się wpis z dokładną ścieżką dostępu i nazwą pliku z pakietem języka polskiego dla edytora tekstu TinyMCE. Teraz kliknij przycisk Wczytaj plik i zainstaluj.

 Podsumowanie instalacji pakietu języka polskiego dla edytora TinyMCE

Po chwili zobaczysz informację o pomyślnym zainstalowaniu pakietu.

Podsumowanie instalacji pakietu języka polskiego dla edytora TinyMCE

Krok 8

Kliknij w oknie Instalacje: Instalator zakładkę Baza danych, aby sprawdzić, czy wszystkie tabele Twojej bazy danych zostały zaktualizowane.

Jeżeli zobaczysz informację, żę jakieś tabele nie są zaktualizowane, kliknij przycisk Napraw znajdujący się w przyborniku okna Instalacje: Sprawdź bazę danych.

Zakładka Sprawdź bazę danych

 

Jeżeli wszystko przebiegło jak należy, to powinieneś zobaczyć ekran informujący o sukcesie zakończonej aktualizacji.

 

 

Chcesz otrzymywać powiadomienia o moich kolejnych wpisach lub projektach?
Wpisz swoje imię oraz adres e-mail a następnie kliknij "ZAPISZ MNIE"

Twoje imię:


Adres email:


Darmowy kurs! Joomla! 2.5
Joomla! 2.5.0

Podobne wpisy

 

Komentarze 17

Gość - ixi w niedziela, 29 styczeń 2012 11:26

wszystko ok tylko łatka z językiem polskim nie do końca przetłumaczona mam problem z com_finder.ini nie chce się wgrać?

wszystko ok tylko łatka z językiem polskim nie do końca przetłumaczona mam problem z com_finder.ini nie chce się wgrać?
Sławomir Pieszczek (website) w niedziela, 29 styczeń 2012 13:20

Dziwne, ja aktualizowałem zarówno na czystej instalacji jak i na działających serwisach, m.in. http://www.slawop.net na którym mam kilka dodatkowych rozszerzeń i wszystko działa bez zarzutu.
Masz jakiś komunikat podczas aktualizacji, że coś jest nie tak?

Dziwne, ja aktualizowałem zarówno na czystej instalacji jak i na działających serwisach, m.in. http://www.slawop.net na którym mam kilka dodatkowych rozszerzeń i wszystko działa bez zarzutu. Masz jakiś komunikat podczas aktualizacji, że coś jest nie tak?
Gość - Pawcio w poniedziałek, 30 styczeń 2012 09:53

Witam, a co z obecnie zainstalowanymi modułami pod 1.7, będą nadal chodziły na 2.5 ?

Witam, a co z obecnie zainstalowanymi modułami pod 1.7, będą nadal chodziły na 2.5 ?
Sławomir Pieszczek (website) w poniedziałek, 30 styczeń 2012 11:31

Należy pamiętać, aby wykonać kopię zapasową, zanim zaktualizujemy swoje serwisy!

Jeżeli masz zainstalowane jakieś inne moduły, to nie wiadomo jak one się będą zachowywać! Generalnie nie powinno być większych problemów, ale sprawdź u twórców tych dodatków, może opublikowali jakieś informacje na ten temat.

[b]Należy pamiętać, aby wykonać kopię zapasową, zanim zaktualizujemy swoje serwisy! [/b] Jeżeli masz zainstalowane jakieś inne moduły, to nie wiadomo jak one się będą zachowywać! Generalnie nie powinno być większych problemów, ale sprawdź u twórców tych dodatków, może opublikowali jakieś informacje na ten temat.
Gość - MK w poniedziałek, 30 styczeń 2012 19:36

Witam,

Niestety podczas aktualizacji z 1.7.3 na 2.5 - w Kroku 3 po kliknięciu "Aktualizuj" - wystąpił błąd

"-1 - Nieznany błąd
Kopiowanie nie powiodło się"

Nie wiem jak sobie z nim poradzić, proszę o pomoc.

--
MK

Witam,Niestety podczas aktualizacji z 1.7.3 na 2.5 - w Kroku 3 po kliknięciu "Aktualizuj" - wystąpił błąd"-1 - Nieznany błąd Kopiowanie nie powiodło się"Nie wiem jak sobie z nim poradzić, proszę o pomoc.-- MK
Gość
piątek, 19 lipiec 2019

Zdjęcie captcha

Najnowsze komentarze

Gość - Andy SSL i Joomla! w Smarthost
03 styczeń 2019
Dzięki, jak zwykle dobra robota! Warto dodać, że instalacja certyfikatu SSL nie zapewnia bezpieczeństwa transmisji danych. To jest możliwe po wdrożeniu polityki bezpieczeństwa w firmie. Co do SSL - to...
Gość - Henryk Jak utworzyć menu poziome w szablonie protostar?
02 styczeń 2019
Robię punkt po punkcie i nie wyświetla się poziome menu Nie wiem gdzie tkwi błąd i co robię źle?Jeśli to możliwe to proszę o pomocps. posiadam książkę "Joomla! 3x" i tu również niema pomocy Pozdrawiam...
Gość - Joanna Jak utworzyć własny szablon dla Joomla! nie dotykając kodu? EF4 cz.2
09 grudzień 2018
Czy jest jakaś możliwość, żeby zmienić układ top-bar i tej linii, w której jest logo? Tam niby są flexibloki ale nie można zmienić ich szerokości, a tego potrzebuję bardzo. Jak tego dokonać???
Gość - Informatyk Tworzenie bazy danych w CPanelu na Smarthost - instalacja Joomla!
19 listopad 2018
Dziękuje za ten wpis joomla zawsze była dla mnie problematyczna
Gość - Sławomir DJ Image Slider
04 listopad 2018
co robić? Zdjęcia wyświetlają się pionowo, jedno pod drugim. Żadna zmiana w opcjach, nic nie daje??? Pomożecie?