A A A

Co nowego w Joomla! 3.6?

przez w Webdesign
  • Przeczytano: 3624
  • 20 komentarze
  • Drukuj
3624
Co nowego w Joomla! 3.6?

Już niebawem pojawi się nowa wersja Joomla! 3.6 :-)

Obecnie dostępna jest wersja Joomla! 3.6 Release Candidate 2. Pamiętaj, że jest to wersja przeznaczona do testów i nie nadaje się jeszcze do aktualizacji działających witryn! Sądzę, że jeszcze w lipcu pojawi się stabilna wersja. Dopiero wówcza należałoby przeprowadzić aktualizacje serwisów.

Od wersji 3.5 Joomla! obsługuje PHP 7, dzięki temu, na serwerach, które mają już zaimplementowane PHP 7, strony oparte o Joomla! będą się znacznie szybciej wczytywać.

Jakie nowe funkcjonalności pojawią się w Joomla! 3.6?

  • ACL dla menu - kontrola dostępu do tworzonych menu;
  • wyświetlanie wszystkich pozycji menu - zarządzanie wszystkimi pozycjami menu za pomocą jednego menadżera pozycji menu;
  • dodawanie kategorii w locie - dodawanie nowej kategorii z poziomu artykułu;
  • ulepszona aktualizacja Joomla! - została dodana możliwość instalacji z pobranego wcześniej pliku z paczką aktualizacyjną;

Grafika promocyjna Joomla! 3.6

ACL dla menu

Bardzo przydatna funkcjinalność, dzięki której możesz teraz zarządzać uprawnieniami do konkretnych menu. 

Możesz dla wybranej grupy użytkowników na przykład umożliwić tworzenie nowych pozycji w wybranym menu. Wystarczy, że w oknie Projektanta menu edytujesz wybrane menu, a następnie klikniesz kartę Menu Permissions. Teraz wystarczy wybrać grupę użytkowników i nadać jej odpowiednie uprawnienia.

ACL dla wybranego menu w Joomla! 3.6

Więcej informacji na temat działania mechanizmu ACL znajdziesz w e-booku: Kurs Joomla! 3.3. Access Control List.

Wyświetlanie wszystkich pozycji menu

Teraz możesz zarządzać wszystkimi pozycjami menu za pomocą jednego menadżera. Wystarczy, że w menu nawigacyjnym zaplecza klikniesz pozycję Menu, a następnie pozycję All Menu Items.

Menadżer wszystkich pozycji menu w Joomla! 3.6 

Dodawanie kategorii w locie

Kolejna bardzo przydatna opcja. Do tej pory najpierw należało utworzyć odpowiednie kategorie, a dopiero potem przypisać im takie elementy jak artykuły, kontakty, czy reklamy. Teraz możesz to zrobić bezpośrednio z poziomu wybranego elementu.

Wystarczy, że podczas tworzenia lub edycji artykułu, kontaktu lub reklamy, klikniesz w polu Kategoria, a następnie wpiszesz nową nazwę kategorii i potwierdzisz ją naciskająć klawisz ENTER na klawiaturze.

Dodawanie nowej kategorii "w locie" w Joomla! 3.6 

Ulepszona aktualizacja Joomla!

W komponencie Aktualizacja Joomla! została dodana karta Upload & Update, za pomocą której możesz zainstalować aktualizację z pobranego wcześniej pliku z paczką aktualizacyjną. Opcja ta przydaje się wówczas, kiedy serwer znajduje się za firewallem lub z jakiś innych powodów nie może połączyć się z serwerami aktualizacji Joomla!

Nowa karta w komponencie Aktualizacja Joomla!

Do pobrania dla Joomla 3.5:

Pamiętaj, że jest to wersja przeznaczona do testów i nie nadaje się jeszcze do aktualizacji działających witryn! 

Chcesz otrzymywać powiadomienia o moich kolejnych wpisach lub projektach?

 

Chcesz otrzymywać powiadomienia o moich kolejnych wpisach lub projektach?

Oceń ten wpis:

Nauczyciel przedmiotów informatycznych w szkole ponadgimnazjalnej.


Pierwszy Certyfikowany Administrator Joomla! w Polsce.


Autor książek i e-booków na temat Joomla!. Autor bloga: www.slawop.net, w którym porusza zagadnienia związane z CMS Joomla! i wykorzystaniu go, jako fantastycznego narzędzia, które ułatwia innym tworzenie ich własnego miejsca w sieci.


Prowadzi własną firmę świadczącą usługi związane z tworzeniem oraz administrowaniem serwisów opartych o CMS Joomla!


Współorganizator Joomla! User Group Jawor


Uwielbia ekstremalnie szybką jazdę na rolkach! Fan rozwoju osobistego i ciągłych zmian :-)


I love Joomla! Why?


Because Joomla! is Doing Great Things with Great People :-)


And My favourite sentence:



Don't Let Anybody Steal Your Dreams!


Komentarze

  • Gość
    Kasia czwartek, 23 luty 2017

    Witam,
    zaktualizowałam serwis z joomla 3.4.5 do joomla 3.6.5 ale niestety nie mogę ani tworzyć ani edytować modułów. Co może być przyczyną?

  • Sławomir Pieszczek
    Sławomir Pieszczek środa, 15 marzec 2017

    Kasia, opróżnij Cache (menu System -> Opróżnij bufor).
    Jak to nie pomoże, to opróżnij także cache swojej przeglądarki.

    Pozdrawiam :-)

  • Gość
    Paweł czwartek, 16 luty 2017

    tworzę stronę w najnowszej wersji joomli 3.6.5 ale niestety mam stary szablon z wersji 2.5. czy istnieje jeakiś sposób przekształcenia go do wyższej wersji?

  • Sławomir Pieszczek
    Sławomir Pieszczek piątek, 17 luty 2017

    Paweł, pewnie, że tak!
    Trzeba dokonać zmian w kodzie plików, aby były zgodne z najnowszą wersją Joomla! ;-)

    Jeżeli szablon był kupiony u jakiegoś developera, to zapewne dostępna jest u niego także najnowsza wersja.
    Alternatywnie możesz sam stworzyć własny szablon korzystając z jednego z wielu dostępnych narzędzi, np. EF4 (https://www.slawop.net/szkolenia/jak-stworzyc-wlasny-szablon-do-joomla-ef4) lub Gantry (https://www.slawop.net/szkolenia/kurs-joomla-wlasny-szablon-gantry4)

    Pozdrawiam :-)

  • Gość
    idoctor poniedziałek, 17 październik 2016

    Wow możliwości joomli nie przestają mnie zaskakiwać! Świetne!

  • Gość
    Cornck piątek, 16 wrzesień 2016

    Dobrze, że Jommla! się rozpędza, bo już wszędzie słychać tylko Wordpress i Wordpress. WP na pewno prostszy i bardziej intuicyjny, ale co do funkcjonalności to zawsze stanę po stronie Joomla, trzeba tylko sobie wszystko przyswoić, bo z WP na Joomla ciężko się przesiąść. Ale odwrotnie to już nie ma problemu.

  • Sławomir Pieszczek
    Sławomir Pieszczek środa, 05 październik 2016

    Dla mnie najprostsza i najbardziej intuicyjna jest Joomla! ;-)

  • Gość
    Adam poniedziałek, 05 wrzesień 2016

    Witam ponownie w sprawie wersji 3.6.x. Po przejściu z 3.5.1 do 3.6.0 (opisywałem to w postach wyżej w lipcu) okazało się, że parę istotnych rzeczy nie funkcjonuje i zgodnie z poradą udało mi się dzięki firmie hostingowej przywrócić stronę sprzed zmiany. Nadal mam więc serwis na 3.5.1. Zaktualizowałem też szablon z EF3 na EF4. Niestety, okazuje się, że najnowsza jego wersja wymaga Joomli 3.6.0. Więc chcę zaktualizować, ale niestety w zapleczu już nie wyświetla się przycisk do aktualizacji jednym kliknięciem. Próbowałem więc ręcznie instalując z pakietu, (jest instrukcja po ang. że aby zaktualizować do 3.6.2 trzeba to zrobić najpierw 3.6.0 a potem 3.6.2) ale za każdym razem pada informacja, że nie znaleziono pliku/katalogu instalacyjnego. Proszę uprzejmie o pomocną radę. Pozdrawiam

  • Sławomir Pieszczek
    Sławomir Pieszczek sobota, 10 wrzesień 2016

    Adam, najpierw kliknij w menu Komponenty pozycję Aktualizacja Joomla! a następnie kliknij link w pozycję: Adres paczki aktualizującej. Zapisz plik w dowolnej lokalizacji, a następnie prześlij go za pomocą FTP do folderu /tmp. Po przesłaniu wejdź jeszcze raz w menu Komponenty / Aktualizacja Joomla! i kliknij przycisk Zainstaluj aktualizację.
    Jeżeli wszystko się powiedzie, to powinieneś mieć Joomla! w wersji 3.6.0.
    Teraz pobierz plik: https://github.com/joomla/joomla-cms/releases/download/3.6.2/Joomla_3.6.x_to_3.6.2-Stable-Patch_Package.zip i zainstaluj go tak, jak rozszerzenie korzystając z instalatora Joomla! (menu Rozszerzenia / Instalacja)

    Pozdrawiam :-)

  • Gość
    Adam środa, 14 wrzesień 2016

    Udało się! Okazało się, że pies był pogrzebany w nieaktualnej wersji bazy danych. Jednym kliknięciem udało się to zrobić i natychmiast pojawiło się w zapleczu '"Joomla! 5.6.0" jest dostępna'. Pozdrawiam z Kaszub!

    Odpowiedz Anuluj
  • Gość
    Adam poniedziałek, 12 wrzesień 2016

    Witaj Słąwku! Dziękuję za odpowiedź. Niestety, gdy wchodzę w menu 'Komponenty' i wybieram "Aktualizacja Joomla!" mam taki komunikat i żadnych opcji:
    "Brak dostępnych aktualizacji
    Jako serwer aktualizacji masz wybraną opcję "Domyślny". Z tego kanału będziesz otrzymywać powiadomienia o wszystkich aktualizacjach bieżącej wersji Joomla (3.x)
    Aktualnie posiadasz najnowszą wersję Joomla: 3.5.1. ".
    Pozdrawiam serdecznie

  • Gość
    Waldek piątek, 15 lipiec 2016

    Zaktualizowałem Joomla 3.5.1 do 3.6 i strona nie działa tzn. padła templatka ale instaluję inne i strona nie działa. Pojawia się tylko napis Strona główna. Instaluję nowe templatki pod Joomlę 3.5omla i te też nie ruszają. Mam prośbę. Czy mógłby Pan napisać jakie katalogi mam skopiować z Joomla 3.5 aby na nowo nie robić instalacji Joomla?

  • Sławomir Pieszczek
    Sławomir Pieszczek poniedziałek, 18 lipiec 2016

    Waldek,

    Po prostu przywróć serwis z kopii zapasowej! :-)
    Bo przecież robisz kopie przed aktualizacją? ;-) Jeżeli nie, to mam nadzieję, że w końcu będziesz o tym pamiętał!
    Zobacz, jak to uprościłoby Ci sprawę. Jak coś się dzieje nie tak, to przywracasz z kopii i tyle. Strona produkcyjna działa, a na komputerze lokalnym przywracasz witrynę z kopii i sobie testujesz z aktualizacją i sprawdzasz, co powoduje błędy itp.itd. ;-)

    Jeżeli nie masz możliwości przywrócenia witryny z własnej kopii zapasowej, to może poproś swoją firmę hostingową. Jeżeli z jakiś przyczyn nie masz kopii lub nie chcesz jej użyć, to spróbuj zainstalować paczkę z aktualizacją 3.5.1, tak jak każde inne rozszerzenie.
    Nie gwarantuję, że będzie w 100% Ok, ale cóż teraz masz do stracenia ;-)

    P.S.
    Zanim zastosujesz moją poradę, zrób kopię zapasową!

  • Gość
    Adam czwartek, 14 lipiec 2016

    Wczoraj zaktualizowałem joomlę do 3.6 (zgodnie z różnymi zaleceniami, że nieaktualizowanie to okazja dla hakerstwa). I niestety, nie działa mi na stronie DJ-Tabs (po prostu nie zamieszcza nowych artykułów), ale najgorsze jest to, że nie zamieszcza na głównej stronie wyróżnionych artykułów. Masakra. A moja działalność to portal informacyjny. Ratunku!

  • Sławomir Pieszczek
    Sławomir Pieszczek czwartek, 14 lipiec 2016

    Adam,
    Po prostu przywróć serwis z kopii zapasowej!
    Mam nadzieję, że zawsze ją wykonujesz przed istotnymi zmianami w serwisie? Praktycznie w każdym artykule na temat aktualizacji piszę grubymi literami, aby ZAWSZE to robić!
    Jeżeli nie masz kopii, to napisz do supportu dj-extensions, na pewno pomogą :-)
    Pozdrawiam :-)

  • Gość
    Adam piątek, 15 lipiec 2016

    Niestety, nie zrobiłem backupu, bo najnowsza akeba żądała wyższej wersji php, odkładałem, odkładałem aż do wczoraj - najpierw szybciutko zaktualizowałem joomlę :p, a potem ręcznie podwyższyłem php do 5.5. Oo. Teraz akeba działa, więc nareszcie backup. Wyjściem z sytuacji okazał się backup zrobiony przez firmę hostingową z 4 lipca :D, więc przywrócili mi. Teraz ręcznie wstawiałem od nowa zdjęcia i artykuły, które na szczęście miałem w swoim kompie. Dzięki bardzo. uff. Pozdrawiam.

    Odpowiedz Anuluj
  • Gość
    Adam piątek, 15 lipiec 2016

    Dziękuję,
    niestety, ostatni backup jest sprzed 9 dni, ale dam radę, ręcznie pościągam materiały, a następnie je wrzucę jeszcze raz. Ale czy w takim wypadku po backupie serwis będzie w wersji 3.5?
    Pozdrawiam :)

  • Sławomir Pieszczek
    Sławomir Pieszczek poniedziałek, 18 lipiec 2016

    Adam, po przywróceniu witryny z kopii zapasowej CMS Joomla! powinien być w takiej wersji, w jakiej był podczas tworzenia kopii zapasowej ;-)

    Pozdrawiam :-)

  • Gość
    yy czwartek, 07 lipiec 2016

    A gdzie nowy sef router? opłacony kilka lat temu na https://www.indiegogo.com/projects/advance-the-joomla-url-router#/ byl juz kilka razy przekladany i mial sie w koncu pojawic w 3.6

  • Sławomir Pieszczek
    Sławomir Pieszczek czwartek, 14 lipiec 2016

    yy,
    Pytasz w zdecydowanie niewłaściwym miejscu :-)
    P.S.
    Wsparłeś ten projekt?

    Pozdrawiam

Zostaw komentarz

Gość
Gość wtorek, 28 marzec 2017

Najnowsze komentarze

Kasia, opróżnij Cache (menu System -> Opróżnij bufor). Jak to nie pomoże, to opróżnij także cache swojej przeglądarki.

Pozdrawiam :-)

Kacper, oczywiście, że tak! Prawie wszystko na temat EF4 znajdziesz tutaj: www.slawop.net/wsdj-ef4 Pozdrawiam :-)

A magistrala 1Wire jaki to typ transmisji danych? I jaka jest róznica między interfejsami szeregowymi a równoleglymi?

Bogdan

Dobry,

Czy powstałe w tym framework'u strony są responsywne?

Kacper

Witam, zaktualizowałam serwis z joomla 3.4.5 do joomla 3.6.5 ale niestety nie mogę ani tworzyć ani edytować modułów. Co może być przyczyną?

Kasia